Ticket #800 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Logout fails

Reported by: BrianKoontz Owned by: BrianKoontz
Priority: high Milestone: 1.1.6.6
Component: core Version: 1.1.6.5
Severity: major Keywords:
Cc: JavaWoman

Description (last modified by BrianKoontz) (diff)

Under some conditions, a user attempting to log out will discover he/she is not able to do so. Thanks to doomedfox for reporting this on the #wikka IRC channel.

Some preliminary tracing of the issue appears to implicate a failure to delete a session record from the wikka_sessions table. The problem was originally reported on a wiki installed on SourceForge, and the problem corrected itself after several attempts to log out.

It turns out this defect had nothing to do with wikka_sessions...read more below about the root cause and solution.

Change History

Changed 6 years ago by DarTar

  • cc JavaWoman added

JavaWoman is experiencing the same issue at the moment.

Changed 6 years ago by JavaWoman

So glad to see I am not alone. ;)

I didn't actually find what caused it, but forcefully deleting all cookies (including non-Wikka cookies ;)) it sort of solved itself. And in my now-modified code (separate login/logout/settings/registration) I cannot reproduce it any more.

I'd have to dig to see what's different; my original code changes for this split were based on 1.1.6.3 so it looks like the problem was introduced in 1.1.6.4 or 1.1.6.5.

Changed 6 years ago by BrianKoontz

(In [1249]) Refs #800: Cookies were being created by installer that did not contain the correct path, so logouts would fail because the wrong cookies were being deleted on logout.

Changed 6 years ago by BrianKoontz

  • status changed from new to accepted

Changed 6 years ago by BrianKoontz

  • status changed from accepted to testing

Changed 5 years ago by BrianKoontz

  • description modified (diff)

Changed 5 years ago by TormodHaugen

  • status changed from testing to commit

I've tested this, and cannot reproduce it anymore.

Changed 5 years ago by BrianKoontz

  • status changed from commit to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.