Ticket #578 (closed task: fixed)

Opened 6 years ago

Last modified 6 years ago

Upgrading from WikiEdit to WikkaEdit

Reported by: OlivierBorowski Owned by: OlivierBorowski
Priority: normal Milestone: 1.1.6.4
Component: editor Version: 1.1.6.3
Severity: normal Keywords: wikiedit wikkaedit editor
Cc: raffa, DotMG

Description

This ticket summarize the changes to switch from WikiEdit (default editor in Wikka 1.1.6.3) to WikkaEdit (default editor in Wikka 1.1.6.4)


1) Small display problem with external link symbol : #577


2) Textarea is too large : #576

WikkaEdit toolbars are inserted just before and after the textarea. Changing textarea style could break WikkaEdit.


3) Installation

- New files : Every scripts and pictures are in /3rdparty/plugins/wikkaedit (done for 1.1.6.4 in changeset [779] [783] [784])

- Existing files : In /handlers/page/edit.php, replace :

if ($this->config['gui_editor'] == 1)
{
    $output .= '<script type="text/javascript" src="3rdparty/plugins/wikiedit/protoedit.js"></script>'."\n".
    '<script type="text/javascript" src="3rdparty/plugins/wikiedit/wikiedit2.js"></script>'."\n";
    $output .= '<script type="text/javascript">'."  wE = new WikiEdit(); wE.init('body','WikiEdit','editornamecss');".'</script>'."\n";
}

with

if ($this->config['gui_editor'] == 1)
{
    $output .= '<script type="text/javascript" src="3rdparty/plugins/wikkaedit/wikkaedit_data.js"></script>'."\n";
    $output .= '<script type="text/javascript" src="3rdparty/plugins/wikkaedit/wikkaedit_search.js"></script>'."\n";
    $output .= '<script type="text/javascript" src="3rdparty/plugins/wikkaedit/wikkaedit.js"></script>'."\n";
}

To save 15kB, you can disable search&replace by removing the "wikkaedit_search.js" related line.

Change History

  Changed 6 years ago by DarTar

  • owner changed from unassigned to OlivierBorowski

  Changed 6 years ago by OlivierBorowski

(In [789]) Use WikkaEdit as GUI editor (WikiEdit is not used anymore), refs #578

  Changed 6 years ago by DarTar

I've tested [789] locally and the WikkaEdit toolbar doesn't show up. Looking at the page source, I see the following (wrongly rendered) error message:

&lt;em class=&quot;error&quot;&gt;Unknown method &quot;page/wikkaedit.js.php&quot;&lt;/em&gt;

  Changed 6 years ago by OlivierBorowski

  • status changed from new to closed
  • resolution set to fixed

As #576 is now closed, I consider the upgrade finished.

  Changed 6 years ago by DarTar

  • status changed from closed to reopened
  • resolution fixed deleted

Reopening the ticket because the issue I reported above is not fixed of the latest version.

There's no hurry to close tickets. In the past we even proposed that tickets should be closed by someone else than the committer. This applies even more so to tickets with issues still pending.

  Changed 6 years ago by NilsLindenberg

@DarTar: Works for me.

  Changed 6 years ago by OlivierBorowski

I've created a ticket for DarTar's bug : #586 (WikkaEdit doesn't work with RewriteEngine enabled)

  Changed 6 years ago by DarTar

(In [796]) Removing WikiEdit files, replaced by WikkaEdit, refs #578

  Changed 6 years ago by OlivierBorowski

(In [797]) Initial revision of WikkaEdit in Trunk, refs #584, #578, #575

  Changed 6 years ago by OlivierBorowski

(In [803]) Use WikkaEdit as GUI editor (WikiEdit is not used anymore), refs #584, #578, #575 Add an additionnal "div" for textarea decorations, this fixes the "textarea-width:100%" bug, refs #576

  Changed 6 years ago by DarTar

  • component changed from unspecified to editor

follow-up: ↓ 15   Changed 6 years ago by BrianKoontz

Edit toolbar does not display after a fresh install of trunk revision 828 (however, the editor textarea is displayed). Tested with FF 2.0.0 and Safari 1.3.2. Confirmed that JS is enabled.

  Changed 6 years ago by DarTar

XHTML validation: required attributes "rows" and "cols" are missing in editor textarea.

  Changed 6 years ago by BrianKoontz

Using the Tab key in the editor text area enters a tab but then places the cursor on the next field (edit notes). User must move cursor back into editor text area after each tab in order to continue editing. This is on OSX 10.3.9 running FF 2.0.0.1. With WikiEdit, CTRL-T correctly placed the tab and kept the cursor on the same line.

in reply to: ↑ 12   Changed 6 years ago by BrianKoontz

Replying to BrianKoontz:

Edit toolbar does not display after a fresh install of trunk revision 828 (however, the editor textarea is displayed). Tested with FF 2.0.0 and Safari 1.3.2. Confirmed that JS is enabled.

This has been moved to #584...please disregard!

  Changed 6 years ago by DarTar

Olivier,

 table markup is not available in 1.1.6.4 but only in 1.1.7 so the table button in WikkaEdit should be hidden.

  Changed 6 years ago by BrianKoontz

Tested using revision 863, FF 2.0.0.1, Mac OSX 10.3.9

Issues:

1. Tab key does not work in editor (jumps to next field). Neither does CTRL-T (jumps to next tab in FF).

2. Hitting the return key in a bulleted list (or numbered list, or commented list) creates the next item, but the cursor immediately jumps to the next (empty) line.

3. When indenting text, text becomes highlighted, which makes no sense because the text is immediately deleted should one attempt to continue with edits.

4. When doing a reverse search, a strange gray box popped up over the edit window (upper right) with two strings: "scroll up" and "log".

  Changed 6 years ago by OlivierBorowski

(In [872]) Split addToLine() into addToLine() and indent()

Use {{table}} syntax instead of table Add new function getSelectionContent() Add new function setTextAreaContent() Add new class SelRange instead of {start:x, end:y} Remove unused function setAreaConcent() Remove unused function getSelection() Fix a bug in addToLine() related to selection when more than 1 line is selected Remove strange loop in js_countTextAreaChars() Some cosmetic changes refs #578, #575

  Changed 6 years ago by OlivierBorowski

(In [873]) Enable table again (use {{table}} instead of table) refs #578

  Changed 6 years ago by OlivierBorowski

(In [874]) Use new functions getSelectionContent(), setTextAreaContent(), SelRange() refs #578, #575

  Changed 6 years ago by OlivierBorowski

(In [879]) Textarea attributes "rows" and "cols" are mandatory for HTML validation, refs #578

  Changed 6 years ago by raffa

more work, juhu...

X) when you star a page with a list, the first item is not displayed correctly. in addition, if you add a blank line, it will be removed, the next time you load the ed.

  Changed 6 years ago by DarTar

  • cc raffa added

Good catch, raffa. These are bugs in the formatter, not WikkaEdit as far as I can tell. Olivier can you please double check this before we open separate tickets for these two issues?

follow-up: ↓ 25   Changed 6 years ago by DotMG

It's okay in trunk. Changesets [472], [473] and [528] need to be ported to 1.1.6.4

It has nothing to do with WikkaEdit.

in reply to: ↑ 24   Changed 6 years ago by DotMG

Replying to DotMG:

It's okay in trunk. Changesets [472], [473] and [528] need to be ported to 1.1.6.4 It has nothing to do with WikkaEdit.

Coordination completed by [919].

  Changed 6 years ago by DarTar

  • cc DotMG added

Thanks Mahefa, Olivier can we close this or are there other pending issues?

  Changed 6 years ago by OlivierBorowski

  • status changed from reopened to closed
  • resolution set to fixed

Migration is finally finished!

The last known bug on FF@Mac OS X has been moved to #657

Note: See TracTickets for help on using tickets.