Ticket #886 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Embedded URLs not rendered properly

Reported by: BrianKoontz Owned by: BrianKoontz
Priority: high Milestone: 1.3.1
Component: formatters Version: trunk
Severity: major Keywords: markup url
Cc:

Description

Under some conditions, embedded URLs in the wiki markup are not rendered correctly as clickable links. This usually occurs when there is a punctuation mark immediately following the URL. The problem is due to the URL regex used to identify the valid portion of an embedded URL.

Change History

Changed 5 years ago by BrianKoontz

  • status changed from new to accepted

Changed 5 years ago by BrianKoontz

(In [1368]) Modified URL regex to correctly exclude adjacent punctuation marks that are not part of an embedded URL. Refs #886.

Changed 5 years ago by BrianKoontz

  • status changed from accepted to testing

Changed 5 years ago by BrianKoontz

  • milestone changed from 1.2 to 1.3

Changed 5 years ago by DarTar

  • status changed from testing to commit

tested, works as described

Changed 4 years ago by BrianKoontz

  • resolution set to fixed

Changed 4 years ago by BrianKoontz

  • status changed from commit to closed

Changed 3 years ago by BrianKoontz

  • milestone changed from 1.3 to 1.3.1

Updated milestone to 1.3.1

Note: See TracTickets for help on using tickets.