Ticket #447 (closed task: fixed)

Opened 8 years ago

Last modified 4 years ago

Move actions to dedicated subfolders

Reported by: DarTar Owned by: DotMG
Priority: normal Milestone: 1.3.1
Component: architecture Version: 1.1.6.2
Severity: normal Keywords: ported
Cc: tormodh@…

Description

(This is a subtask of #446)

Change History

Changed 8 years ago by DarTar

  • status changed from new to closed
  • resolution set to fixed

done in [369]

Changed 8 years ago by DotMG

  • status changed from closed to reopened
  • resolution fixed deleted

Please doublecheck actions/colour/colour.php

include statement may need to be recoded (add colour/ path).

Changed 8 years ago by DarTar

(In [422]) Fixing wrong path to feedcreator class. Thanks Mahefa for spotting this. Refs #447

Changed 8 years ago by DarTar

(In [423]) Fixing wrong path to color action, refs #447

Changed 7 years ago by DarTar

  • status changed from reopened to closed
  • resolution set to fixed

Reclosing this ticket after the above changes.

Changed 6 years ago by DarTar

  • milestone changed from 1.2 to 1.3

Retargeting to 1.3, this ticket has already been closed in trunk, from which 1.3 will be branched. Consider backporting urgent issues to 1.2.X

Changed 5 years ago by BrianKoontz

(In [1483]) Ported from trunk to 1.2 branch. Refs #446, #447.

Changed 5 years ago by BrianKoontz

  • keywords ported added

Changed 5 years ago by BrianKoontz

  • status changed from closed to reopened
  • resolution fixed deleted

Changed 5 years ago by BrianKoontz

  • owner changed from DarTar to BrianKoontz
  • status changed from reopened to assigned

Changed 5 years ago by BrianKoontz

  • status changed from assigned to testing

Changed 5 years ago by DotMG

  • status changed from testing to assigned

Performed an exhaustive test on all actions and found issues in the following actions : backlinks, calendar, colour, contact, feedback, files, highscores, lastedit, lastusers, ownedpages, rss, textsearch, wantedpages. On some, the issue is just a matter of Notice (uninitialized variables), on others it is more serious :

  • feedback : syntax (fatal) error
  • ownedpages : false results (returns pages owned by user "" (blank) )
  • colour : action ignored if called after a previous call to {{color}} or {{colour}}
  • files : use of inexistent variable $this->method (which is now called $this->handler)
  • rss : config('onyx_rss') not defined makes the action unusable.

Changed 5 years ago by DotMG

  • owner changed from BrianKoontz to DotMG

Changed 5 years ago by DotMG

  • status changed from assigned to testing

Fix done in [1638]

Changed 4 years ago by BrianKoontz

  • cc tormodh@… added

All the action changes look great. Tormod, can you take a look at the TableMarkup page and see what you can do about the notices? I'd fix them, but I'm not quite sure what the "hints" array is all about.

Changed 4 years ago by BrianKoontz

(In [1669]) Fixed notices. Probably not the best fix, but this ticket has been languishing for 6 weeks. Refs #447.

Changed 4 years ago by BrianKoontz

  • status changed from testing to commit

Changed 4 years ago by BrianKoontz

  • status changed from commit to closed
  • resolution set to fixed

Changed 4 years ago by TormodHaugen

(In [1708]) Fixes attribs that broke in [1669]. Refs #447.

Changed 4 years ago by BrianKoontz

  • milestone changed from 1.3 to 1.3.1

Changed milestone to 1.3.1

Note: See TracTickets for help on using tickets.